Website Access Issues

Incident Report for Finalsite

Resolved

This incident has been resolved. We apologize for any disruption this may have caused. Please reach out to our Support Team with any additional questions or concerns.
Posted Apr 15, 2025 - 14:27 EDT

Investigating

We are currently investigating issues with one of our servers in the US Central region. Some users may have trouble logging in or accessing certain data. We are working to analyze and mitigate this problem.
Posted Apr 15, 2025 - 13:29 EDT
This incident affected: School Websites (Composer US Central).